Jump to content
Sign in to follow this  

Starcraft Lag Help

Recommended Posts

Aight.. I don't have a new computer, just a new tower (for where I put the cd in).

 

On my old tower, I didn't have any lagging problems in games or nothing. Just everything was just running smooth n' shit. Now, on this new tower I got, whenever I join a game, I lag right there in the chat-mode area before the game starts. Then I lag even worse when the game starts. And I can't find out why I'm lagging with this new tower.

 

Anybody can help me out here? Tryna fix this lag problem during my game-play.

Share this post


Link to post
Share on other sites

I don't really get it. However, I think you should try playing without CD, either by using an ISO or doing the Patch 1.15.2 add-on's miracle of copying the install.exe to the dat.

Share this post


Link to post
Share on other sites

If it's you computer, and the game is running more slowly, try to do what zhuiden said, that came with the 1.15.2 patch, sand see what happens. Also, a slow connection to bnet could mean that.

Share this post


Link to post
Share on other sites
I don't really get it. However, I think you should try playing without CD, either by using an ISO or doing the Patch 1.15.2 add-on's miracle of copying the install.exe to the dat.

 

Yeah.. I just played without the disk, and I seem to still lag in the channel b4 the game starts.

 

 

Poply.. I don't think it's the network lag. It might be the client lag, but I'm not sure.

 

Dead Man.. Nah, I don't have apps running while I'm tryna game. It's just the computer that I replaced, not the monitor.

 

 

But idk though.. I read some of the same problems off of google, and most of them had something to do with their ports, but idk how all that works n' shit.

Share this post


Link to post
Share on other sites

If it only happens when there is more than one person in the game, you haven't opened your firewall for your ports on the computer. If they were open before and you have static addressing, the ip will have changed on the network and you will need to re open the port.

 

Happy to help.

Share this post


Link to post
Share on other sites
you just need a new pc, or lower the starcraft quality so it look squikky

 

Please don't post in technical support.

 

 

If my last post was un-understandable, allow me to organize.

 

1. If you have static addressing, your PC has a new LAN ip

2. This means you have to re-allow it through port 6112

3. I know it's port trouble, because you said you only lag with more than one other person. I believe.

Share this post


Link to post
Share on other sites
you just need a new pc, or lower the starcraft quality so it look squikky

 

Please don't post in technical support.

 

 

If my last post was un-understandable, allow me to organize.

 

1. If you have static addressing, your PC has a new LAN ip

2. This means you have to re-allow it through port 6112

3. I know it's port trouble, because you said you only lag with more than one other person. I believe.

 

It might be port trouble. But I had re-started my computer over, and tried the "play Starcraft w/o a disk" and it worked. I don't lag as much as I did before I tried it. I just seem to have lag spikes now. Maybe like every 2-5 mins in a game now.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×